Scroll Station


Scroll Station

Author
Message
Eppa02
View Quick Profile

Supreme Being
Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)Supreme Being (77 reputation)

Group: Forum Members
Last Active: 11 Years Ago
Posts: 3, Visits: 15
Hi all,

I have the scroll station 1830 I think, I just upgraded from the ryobi

The only trouble I seem to be having is when I put the blade in and I  pull the lever to tighten the blade-it's sometimes seems to be loose  --then I turn the lever to tighten it again and it's still loose--is there something that i'm doing wrong--I don't want to break the lever..could someone please help---

Kurgan
View Quick Profile

Supreme Being
Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)Supreme Being (1.9K reputation)

Group: Forum Members
Last Active: 10 Years Ago
Posts: 96, Visits: 362
Eppa, I don't have a scroll saw, but since no one has replied as of yet, I recommend you contact customer service. If you scroll to the top of this page you can click on the Customer Service button and contact Dremel directly for help. As you will note, from an other post this week they are very prompt in replying. I wish you well.

Thanks,



Kurgan
rja
View Quick Profile

Supreme Being
Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)Supreme Being (588 reputation)

Group: Forum Members
Last Active: 7 Years Ago
Posts: 24, Visits: 140
I have an 1830 Scroll Station and have experienced this problem. The problem I had was the blade slipped in the blade holder because I did not seat the blade properly and the screw in the blade holder did not tighten and hold the blade while I pushed the lever down. Try inserting the blade all the way down (or up in the case of the upper blade holder) and all the way back into the holder(s) before tightening the screw. If properly inserted, a great deal of tension can be applied and the blade will not slip.


Reading This Topic